Configuración de PAT, overload o sobrecarga

La forma más utilizada de NAT proviene del NAT dinámico, ya que toma múltiples direcciones IP privadas y las traduce a una única dirección IP pública utilizando diferentes puertos. Esto se conoce también como PAT (Port Address Translation), NAT de única dirección , NAT multiplexado a nivel de puerto o sobrecarga (overload).
          1. Primero deberemos definir una lista de acceso IP estándard que permita las direcciones locales internas que se deben traducir:
Router(config)# access-list 1 permit  192.168.8.0 0.0.0.255
          2. Establecer la traducción dinámica de origen, especificando la lista de acceso definida en el paso anterior.
Router(config)# ip nat inside source list 1 interface serial0/0 overload
nota: “la palabra overload habilita PAT”
          3. Especificar la dirección global como un conjunto  que se usará para la sobrecarga.
Router(config)# ip nat pool 1 179.9.8.20 netmask 255.255.255.240
          4. Establecer la traducción de sobrecarga:
Router(config)# ip nat inside source list 1 pool 1 overload
         5. Especificar la interfaz interna y marcarla como conectada al interior.
Router(config)# interface e0
Router(config-if)# ip nat inside
Router(config-if)# exit    
         6. Especificar la interfaz externa y marcarla como conectada al exterior.
Router(config)# interface s0
Router(config-if)# ip nat outside

Router(config-if)# exit

Advertisements

Configuración NAT dinámica

La NAT dinámica está diseñada para mapear una dirección IP privada a una dirección pública de entre un pool de direcciones públicas ya establecido. Es decir, Cualquier dirección IP pública de este pool se asigna a un host de la red interna.
          1. Primero deberemos definir un almacén o pool de direcciones (que serán las direcciones públicas que nos asigne nuestro ISP) 
Router#config t
Router(config)# ip nat pool 1 179.9.8.80 179.9.8.95 netmask 255.255.255.0
          2. Crear una lista de acceso estándard que permita las direcciones internas que se deben traducir.
Router(config)# access-list 1 permit  192.168.8.0 0.0.0.255
          3.Configurar la NAT dinámica basada en la dirección de origen especificando la lista de acceso definida en el paso anterior.
Router(config)# ip nat inside source list 1 pool 1
          4.Especificar la interfaz interna y marcarla como conectada al interior.
Router(config)# interface e0
Router(config-if)# ip nat inside
Router(config-if)# exit    
           5.Especificar la interfaz externa y marcarla como conectada al exterior.
Router(config)# interface s0
Router(config)# ip nat outside
Comandos para verificación de la tabla NAT
Show ip nat  translations
Show ip nat statistics
debug ip nat


Configuración NAT estática

NAT puede funcionar de forma estática o dinámica.
La NAT estática puede ser útil para host  internos que deben ser accesibles desde internet como servidores DNS, servidores web o de correo electrónico.
Se configuran direcciones en una tabla de búsqueda y se asocian una por una de forma estática.
Configuración de NAT estática: ( donde 10.1.1.2 es ip-local y 80.37.203.25 es ip-global )
Router#config t
Router(config)# ip nat inside source static 10.1.1.2  80.37.203.25
Router(config)# interface s0
Router(config-if)# ip nat outside
Router(config)# interface e0
Router(config-if)# ip nat inside


Error: las carpetas publicas no són accesibles desde OWA

Para que las carpetas públicas sean accesibles, “HTTP keep alive” debe estar habilitado en la configuración de IIS.
IIS Admin => propiedades de  “Default web site” => pestaña Web Site:  marcar el checkbox  ‘HTTP keep alive’  y reiniciar los servicios del directorio virtual y de IIS.


Error: aparace un directorio de tipo FTP al logarme en Exchange

Al acceder via OWA a Exchange usando protocolo http y https no puedo acceder a los buzones y aparece en pantalla un directorio tipo FTP cuando me logo.
Este error puede ocurrir si el path Davex.dll no está entrado en la configuración del directorio virtual de Exchange.
Con los valores por defecto, solo el directorio , Exchange, exchadmin y public  tienen la configuración mapeada para usar Davex.dll
Solución:
En IIS eliminar el Directorio Virtual de Exchange.
En ESM deshabilitar el acceso por formulario en el directorio virtual del protocolo HTTP.
Reiniciar el servicio Microsoft Exchange System Attendant, para que cree con los valores por defecto el Directorio Virtual de Exchange.
Esta operación tardará aproximadamente unos 15 minutos, por tanto no estará disponible el acceso al servidor via OWA.
Cuando ya sea accesible y se compruebe que se puede acceder a los buzones usando protocolo http y https, habilitar de nuevo el acceso a través del formulario.